From IncendiaWiki
Jump to: navigation, search

Transparency Tutorial Final.jpg

This tutorial is oriented to generated images with transparencies.
Incendia by default doesn't support transparencies (future versions will do), but they can be done by making a three step process:

  1. Rendering the Opaque elements.
  2. Rendering the Transparent elements.
  3. Combining them in a graphic editor program.

The Tutorial presented here uses the The Gimp, since its a freely image composition editor.

The Opaque Elements

This section is pretty simple, you just has to run Incendia, select a baseshape and render it:

  • Run Incendia
  • Go to the Baseshape Editor.
  • Select the Atom Baseshape.
  • Set the Iteration Depth to 4.
  • Close the Baseshape Editor.
  • Press the Render button.
  • Once the render is clear, save the bitmap.
  • (Optional)Save the resulting buffer.

I have included and example parameter this section: Transparency Tutorial Part I
And here is how it looks:

Transparency Tutorial I.jpg

The Transparent Elements

There are two possible paths ways to render the transparent elements:

  • Method 1: Adding the transparent baseshapes and re-rendering the whole image.
  • Method 2: Loading an already saved buffer and appending the transparent baseshape.

The second method is the faster, since you don't need to render the whole scene again.

Method 1

  1. Run Incendia.
  2. Load the parameter that has the solid elements.
  3. Open the Baseshape Editor.
  4. Create a new Sphere baseshape.
  5. Set the Iteration depth count to be the same as the solid element (the atom).
  6. Change the Material index to 1.
  7. Close the baseshape editor.
  8. Go the Render Tab and do the following changes:
    1. Select the first texture slot(#0).
    2. Change the Ambient Texture to black.
    3. Change the diffuse Texture to black.
    4. Set the Specular Intensity to 0.
    5. Change the texture slot to #1.
    6. Set the Ambient Texture to something crystaline (bluish color, for example).
    7. Set the Diffuse Texture to a texture that looks like a reflected glass.
  9. Render the fractal
  10. Once the image is clean, save it (with a different name).

Method 2

  1. Run Incendia
  2. Load the previous saved Buffer.
  3. Open the Baseshape Editor.
  4. Create a new Sphere baseshape.
  5. Set material index to 1.
  6. Close the Baseshape editor.
  7. Carefully (without changing the camera orientation), follow Method 1 step #8.
  8. Continue the Render.
  9. Once its clean, save the resulting image.

I have included and example parameter this section (Method 1 or 2): Transparency Tutorial Part II
And here is how the final result looks:

Transparency Tutorial II.jpg


Now you have two different images, one with the opaque elements and the other with the transparent elements. It's time to combine them:

  • Run The Gimp.
  • Open the Opaque element image (File->Open).
  • Use The Open as a Layer option located in the File Menu to open the Transparent elements image (File->Open as a Layers..).
  • Go to the Layer,Channel,Path.. window and select the Top layer.
  • Change the Layer Mode from Normal to Screen

Now you will see the Transparencies.
This table shows two screen captures of The Gimp elements:

Here is a Gimp file (scaled down) with the changes made:Transparency Tutorial
The final result can be seen in the top of this page.

Multiple Layers

You can use more than just one layer, if you want to add multiple transparent object. The procedure is the same as in the single layer example:

  1. Generate the Opaque element and render.
  2. Save the buffer and the image.
  3. Add the Transparent element.
  4. Change the materials and render.
  5. Save the image.
  6. Reload the buffer.
  7. Repeat from Step 3.

To combine multiple Transparent layers on the Gimp you can use either the Screen or the Addition layer mode.
Here is an example how it looks: